Shopping Basket

 x 

Cart empty


Log In

Find Us Elsewhere

SSL

Forum Search

Keyword

Read More link does not link to the right page

  • svalenti
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
6 years 6 months ago - 6 years 6 months ago #397 by svalenti
When I click on "read more", it keeps me on the Home page instead of linking to the page with the article on it.

Here's my site: thelion.fm

Please help.
Last edit: 6 years 6 months ago by svalenti. Reason: added url

Please Log in or Create an account to join the conversation.

More
6 years 6 months ago #400 by boggler
Hello, I don't think this is a problem with the module, it seems to be a problem with your SEF urls.

The module displays what look the correct links, eg

thelion.fm/7-community-news/15-lion-spring-2012-recruitment
thelion.fm/7-community-news/10-home-gardeners-school-committee

There is nothing wrong with these URLS that I can see, they are not links to your home page. If your site is redirecting them to your home page then there is a problem with your SEF URLS somewhere, they are not set up correctly.

There is a guide to setting up Joomla SEF URLS here: http://docs.joomla.org/Enabling_Search_Engine_Friendly_%28SEF%29_URLs_on_Apache

Please Log in or Create an account to join the conversation.

  • Visitor
  • Visitor
4 weeks 1 day ago #8082 by
Hello!

>>The module displays what look the correct links, eg
>>thelion.fm/7-community-news/15-lion-spring-2012-recruitment
>>thelion.fm/7-community-news/10-home-gardeners-school-committee

Tried to find similar issues on this forum but unable to do it. Please help.
I have discovered that module didn't link to Joomla menu system. It have be redirecting to correct name, but it showing standard SEF urls. Is it possible to fix?

For example:
There was created menu item website.com/lion-spring2012, but module is showing:
website.com/7-community-news/15-lion-spring-2012-recruitment

Please Log in or Create an account to join the conversation.

More
3 weeks 5 days ago - 3 weeks 5 days ago #8084 by boggler
Sorry, but I don't think that there is an automatic fix for this, this is basically the way that Joomla handles URLs. The module uses the Joomla router to calculate the URL for the article, which it does correctly.

The Joomla router doesn't seem to take into account if this happens to be a menu item.

The only way I think this could be solved is to override the link for the article, which could be done by setting a link option for an individual article. We could do this for you, but as this is a free module we would need to do this as a custom programming job.

Otherwise we might do this in future releases, but this will not be for some time, as the module needs to be substantially rewritten to be compatible with Joomla 4 which is going to take a lot of work.

Sorry but your user account got deleted. I tend to delete user accounts with obviously bogus user details, because these tend to be spammers, and it saves having the database filled up with junk accounts. This is before I realised that you posted in the forum. If you need to post a reply you will need to create a new account.
Last edit: 3 weeks 5 days ago by boggler.

Please Log in or Create an account to join the conversation.

Moderators: boggler
Time to create page: 0.259 seconds

Donate to Us

If you like our extensions, consider making a donation to say thanks.