Shopping Basket

 x 

Cart empty


Log In

Find Us Elsewhere

SSL

Forum Search

Keyword

Joomla's new experimental routing seems to change layout for Content AmazonWS

1 month 1 week ago #4042 by scarney
I thought you might want to test this out just for fun. I am still playing with Joomla vs EasyBlog and thought that since Joomla now has the new routing tool I might be able to get urls for the shopping cart system that do not contain the item IDs. Anyhow, I tried to see how that works and discovered that when the Eperimental routing option is turned on the layout changes on a page that uses the shortcode.

Here is the url of the page with the regular stable joomla routing that uses the id numbers:

www.drcarney.com/shop/amazon-storefront/authors/8-author-1-test

When I go to the Joomla article options, click on the Integration tab and then change the option for URL Routing to Experimental and then click "Yes" for the Remove IDs from the URLs option and then Save. the following happens:

The URL improves to www.drcarney.com/shop/amazon-storefront/authors/author-1-test

But... the layout completely changes to what I think it maybe a blog layout.

Just thought you would like to know.

I have put it back to using the Core Joomla routing for now but if I do decide to use Joomla instead of EasyBlog then I would totally wish to be able to get rid of those ids in the urls!

Sean

Please Log in or Create an account to join the conversation.

1 month 1 week ago - 1 month 1 week ago #4044 by scarney
I was able to get the article layout to display with the new routing by setting the Plugins: Content AmazonWS default Blog Layout to "article" in the plugin. But the Similar Products section then stopped displaying images. In case you want to see it I have left the Experimental routing on. It is visible at www.drcarney.com/shop/amazon-storefront/authors/author-1-test

Please Log in or Create an account to join the conversation.

1 month 5 days ago #4049 by boggler
OK, thanks for letting us know. It sounds like a bug with the new routing system, it is detecting the layout as 'blog' when in fact it is not.

If you have not already done so then it would be a good idea to update to version 3.8.1, it fixed quite a few bugs that appeared with 3.8.0, it is possible that the issue may just go away.

If not then we will look into this for the next release. At the moment, because the new routing system is experimental, it is liable to change, so it is difficult to know which issues are real ones that need to be fixed, and which are just bugs that will disappear in new versions of Joomla.

We are planning to start work on a new release around the end of this month, so hopefully it will be a bit clearer by then.
The following user(s) said Thank You: scarney

Please Log in or Create an account to join the conversation.

1 month 4 days ago #4056 by scarney
I am using version 3.9.1 of the Content AmazonWS plugin. I am assuming this is the latest one?

It would be great if you could make it work with the Experimental routing. I really want to use that if I use Joomla because I had those id numbers in the urls. :-)

The end of the month should be here soon enough. I am looking forward to trying out your next version.

Thank you, Sean

Please Log in or Create an account to join the conversation.

1 month 3 days ago #4059 by boggler

I am using version 3.9.1 of the Content AmazonWS plugin. I am assuming this is the latest one?


Yes, that is the latest version. Actually I meant 3.8.1 of Joomla, it fixed quite a few bugs that were introduced in Joomla 3.8.0.

I did some experimenting with Joomla 3.8.1 with the experimental URLs enabled. It does seem that there is an issue with the 'blog' layout being incorrectly detected when a single article is viewed. It only happens when the article has been reached by clicking through from a category blog menu item, if the article is viewed as a single article menu item then the issue does not arise. I am pretty sure that I know why it happens and it should not be difficult to fix, which we will do in the new release.

I did not find any issue with the similar products plugin not being displayed, I think that this was due to a bug that was fixed in Joomla 3.8.1.

Please Log in or Create an account to join the conversation.

1 month 3 days ago #4063 by scarney
Thank you. I did upgrade about a week ago to Joomla 3.8.1. :-)

Please Log in or Create an account to join the conversation.

1 month 3 days ago #4064 by scarney
I am thinking that the Similar Products plugin is also not working with the Experimental routing:

www.drcarney.com/shop/amazon-storefront/authors/author-1-test

Please Log in or Create an account to join the conversation.

1 month 2 days ago #4067 by boggler
It definitely is working with the experimental URLs, we have tested it.

I think this is an issue with your site, you have several javascript errors on that page, this can cause javascript to stop being executed altogether, with the effect that the similar products do not load as they use Ajax loading.

The script that seem to be causing an issue are these:

hxxps://cdn.onesignal.com/sdks/OneSignalSDK.js
hxxps://www.google-analytics.com/analytics.js
The following user(s) said Thank You: scarney

Please Log in or Create an account to join the conversation.

Moderators: boggler
Time to create page: 0.165 seconds